Results 1 to 5 of 5

Thread: Fuel Pump location and prime on 79 280ZX

  1. #1

    Default Fuel Pump location and prime on 79 280ZX

    I just inherited a 79 280ZX as a high school graduation present. My dad and I are trying to get it going but the car sat for a good number of years. We used starter fluid to see if it would start and it does now we need to get fuel to the injectors. Any recommendations on how get the system primed? Any help is greatly appreciated.

  2. #2
    Supporting Member ChrisA's Avatar
    Member ID
    CZCC-5906
    Join Date
    Feb 2004
    Location
    Lincoln, NE
    Age
    51
    Posts
    1,471

    Default

    If the stock fuel pump is working, when you turn the key to "ON" the pump should run and prime the system. You may have to lay under the car and have someone kit they key while you listen for the pump. They are sometimes very quiet. I have seen some people plumb a pressure gauge into the fuel rail to see what pressure they're getting. Check your fuel pump relay in the engine bay and any fusible links or fuses also. Good luck!!

  3. #3
    Supporting Member ChrisA's Avatar
    Member ID
    CZCC-5906
    Join Date
    Feb 2004
    Location
    Lincoln, NE
    Age
    51
    Posts
    1,471

    Default

    Forgot to say the pump is either right outside the fuel tank or in it on a ZX but I'm not 100% on that. Havent had a ZX since 1983.

  4. #4
    Known Zitus carrier! hls30.com's Avatar
    Member ID
    CZCC-4106
    Join Date
    May 2003
    Location
    Savannah, Georgia
    Posts
    6,702

    Default

    You probably have a blocked fuel line. First I would do the obvious-check and replace the fuel filter. Remove the old one and try to blow through it-if you can keep looking. I even put pressureized air through both the return line and the feed, the return line was not blocked, but the feed line was. The next obvious place is the pickup. Under the carpet and the pad, in the hatch area floor there is a round panel with two bolts through it. Remove the two bolts, and the cover and your pickup is staring you in the face. It is a held in the tank with a bunch of bolts. Remove the hoses and disconnect the gage sender, remove the bolts and carefully remove the pickup. you may have to gently . When I took mine out it was completely clogged-even the basket type pre filter. I used two cans of Carb-cleaner, an acid brush and a length of copper wire to clean it out. First I sprayed cleaner in a container, and immersed the basket in it. After a good soak, I used the brush to gently clean the basket, the outside of the tube, and the electrical contacts. Then I went to work on the tubing, I flattened and sharpened the end if the wire, and worked it into the tube in a twisting motion, rinsing the crap that came loose out with carb cleaner It clog was not hard, but it did take a while to clear. Then I pulled pieces of a scotchbrite pad through the tube and rerinsed it thoroughly.
    I repalced the pickup and the car fired right up!

    Remember this is all being done around Gasoline-disconnect the battery, no smoking, and remember the life you save by being too careful WILL be your own! An extra 10 minutes of careful preparation could easily save a set of services, a lengthy stay in the hospital, or both!
    Will
    A Z is beautiful from any angle, I just happen to prefer to view from the drivers' seat!

  5. #5
    Former frequent poster sblake01's Avatar
    Member ID
    CZCC-3797
    Join Date
    Mar 2003
    Location
    San Bernardino, Ca. U.S.A.
    Age
    69
    Posts
    10,574

    Default

    From what I understand, those pumps are self-priming. If it starts with starting fluid and the dies, check your fuel pump as ChrisA said. It's outside of the tank passenger side. If it is working then you probably have the problem that comes from the car sitting long periods of time. Crud (for lack of a better term) in the tank. When I bought my 280 it had been sitting for four years. We could get it to start but it wouldn't run much beyond and idle. After checking the fuel pump, lines, relays, etc. which all were good we checked the fuel pressure. It was low. It turned out to be clogged passages in the tank from the residue from the fuel sitting for so long. Some people have the tank professionally cleaned out but that can be pricey. I bought one from a car that had just come into the junkyard and the car has been fine (at least in that area) ever since. If you do get to that point make sure you get a tank from the year span that covers your car.
    2004 Ford Ranger EDGE Supercab
    (@Moonpup: This one really is an EDGE!)
    2005 Pontaic GTO
    2010 Mercedes Benz C300 AMG Sportline (Wife's car)
    2014 Kia Rio LX (Wife's daily driver)
    Certified HVAC/MVAC Technician

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •