Results 1 to 7 of 7

Thread: Leaking Dellortos

  1. #1
    Registered User biker's Avatar
    Member ID
    CZCC-2906
    Join Date
    Sep 2002
    Location
    Brisbane Aust
    Posts
    328

    Default Leaking Dellortos

    I have just installed some tripple 40mm Dellorto's and have a problem with the leaking of fuel out of the ram tubes. My undertstanding is that this is caused by too much fuel pressure pushing the fuel past the seat. (The seats are 1.5 size)

    I have Holley Red fuel pump mounted at the fuel tank and a Speco Fuel Regulator which is mounted just in front of the rocker cover on an L28 motor.

    However, to get enough pressure to the third carby, I need to push the regulator up to 5psi which causes the first 2 carbys to flood. If I turn the fuel regulator down to 3psi the carbys stop leaking but the thrid carby does not get any fuel.

    I have changed the hoses around to try and get more pressure to the rear carby but without result.

    Not sure if this is the problem but would welcome any ideas, e.g. setting up a fuel rail, multiple fuel lines?

    Has anyone else encountered this issue?

    Thanks for your help in advance

    Biker
    Last edited by biker; 06-24-2007 at 04:09 AM.
    Spending too much again!

  2. #2
    Registered User biker's Avatar
    Member ID
    CZCC-2906
    Join Date
    Sep 2002
    Location
    Brisbane Aust
    Posts
    328

    Default

    Any hints anyone??
    Spending too much again!

  3. #3
    Registered User
    Member ID
    CZCC-8541
    Join Date
    Jun 2005
    Age
    76
    Posts
    263

    Default

    Check your float levels.

  4. #4
    Semi-retired admin Arne's Avatar
    Member ID
    CZCC-8596
    Join Date
    Jun 2005
    Location
    Eugene, Oregon, USA
    Age
    62
    Posts
    8,465

    Default

    Sounds like too much restriction in the fuel lines between the carbs. Do you have a fuel rail? Or are you daisy-chaining them?
    Arne - Former owner, HLS30-37705, 7/71, 905 Red
    Car blogs - 240Z - Porsche 911

  5. #5
    Registered User biker's Avatar
    Member ID
    CZCC-2906
    Join Date
    Sep 2002
    Location
    Brisbane Aust
    Posts
    328

    Default

    Quote Originally Posted by Nigel1943 View Post
    Check your float levels.
    Checked the float levels and they are okay and in spec.

    I was daisy chaining but have now redeployed the standard fuel rail line from the SU and coupling one and three to the centre carby. this did not solve the problem either. It is only the first carby that leaks. Will play around with the floats again.

    Thanks guys - still welcome any further suggesstions.

    Biker
    Spending too much again!

  6. #6
    Registered User graham53's Avatar
    Member ID
    CZCC-13689
    Join Date
    Jan 2007
    Location
    sc
    Age
    66
    Posts
    72

    Default

    I am having the same problem. Do you or should you have a return line? and will this help?

  7. #7
    Registered User biker's Avatar
    Member ID
    CZCC-2906
    Join Date
    Sep 2002
    Location
    Brisbane Aust
    Posts
    328

    Default

    Quote Originally Posted by graham53 View Post
    I am having the same problem. Do you or should you have a return line? and will this help?
    I got the old 2 outlet fuel line for the SU's back on and am using the return line incorporated in that. did not solve it though. I have noticed that the rear carby will not get any fuel unless the regulator is turned up to 5psi. Under this pressure, there is no fuel coming out of the hose from the fuel line even when the fuel pump is whirring away.
    Spending too much again!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Tranny Seals Leaking?
    By Pennyman in forum Help Me !!
    Replies: 2
    Last Post: 07-30-2005, 10:22 AM
  2. tranny leaking fluid inside bellhousing
    By Dreco in forum Help Me !!
    Replies: 7
    Last Post: 02-21-2005, 11:28 AM
  3. carb leaking gasoline
    By zanos in forum Help Me !!
    Replies: 4
    Last Post: 02-19-2005, 09:38 AM
  4. Brakes leaking
    By 240Zdragon72 in forum Wheels, Tires and Brakes (S30)
    Replies: 7
    Last Post: 04-18-2004, 11:38 AM
  5. leaking hatch
    By mdbrandy in forum Body and Paint (S30)
    Replies: 10
    Last Post: 11-20-2003, 06:23 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •