Results 1 to 3 of 3

Thread: Any Help greatly appreciated-Hesitation

  1. #1
    Registered User
    Member ID
    CZCC-17495
    Join Date
    Aug 2008
    Location
    Santa Rosa, Ca.
    Age
    56
    Posts
    5

    Default Any Help greatly appreciated-Hesitation

    Hi new to the forum, I have a 77 280z 4sp sat for 15 years, worked on it every few years because of fuel problem. getting divorced and need the car, had choice keep wife or car chose my z. Initially removed tank had it boiled and lined car still didn't run. Now I have discovered fuel tank is blocked internally, so I installed a new outflow line threw drain plug of tank, blocked existing outflow line. Installed new fuel pump,, changed plugs filter, car started right up and ran rough but ran. Problem is now that after driving a couple miles the car hesitates, backfires some when driving and then doesn't go, and drops to idle, i step on gas idles goes up abit then down to idle. I then turn car off, and restart it a couple minutes later and its fine again for a little bit, replaced pump and get 36 lbspressure, fuel seems to travel throughout lines, I am getting spark,Can it be something electrical, or module, relays? when opening the door on AFM the pump starts. I'm sure more info is needed to diagnose. I've been searching the forums but haven't located answer yet and I have to move the car. Thanks
    Aleck

  2. #2
    Registered User
    Member ID
    CZCC-14965
    Join Date
    Aug 2007
    Location
    Temecula
    Age
    28
    Posts
    3

    Default

    Have you checked the fuel damper and the pressure regulator?

  3. #3
    HS130-150591 4/79 zbane's Avatar
    Member ID
    CZCC-11908
    Join Date
    Jun 2006
    Location
    Cashiers, NC
    Age
    46
    Posts
    1,671

    Default

    So the tank line was clogged...
    Have you taken the time to check the integrity of the rest of the fuel system? There is a small screen on your fuel pump-could be getting clogged. How old is the fuel filter? Could be full of same crud.
    Electrical-how are all of your electrical connections?
    David
    _____________________________________
    HS130-150591, April, 1979-280zx
    2001 Infiniti I 30

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Z left me stranded, any help appreciated
    By janaka in forum Help Me !!
    Replies: 23
    Last Post: 07-23-2007, 06:08 AM
  2. Not passing smog. Suggestions appreciated
    By Esteves in forum Open S30 Z Discussions
    Replies: 14
    Last Post: 06-16-2006, 05:12 PM
  3. Hesitation
    By reethij in forum Help Me !!
    Replies: 1
    Last Post: 05-18-2006, 01:42 PM
  4. any input would be greatly appreciated
    By seekNdestroy2x4 in forum Help Me !!
    Replies: 3
    Last Post: 03-20-2006, 04:35 AM
  5. Hesitation???
    By Stryder in forum Open Discussions
    Replies: 4
    Last Post: 01-28-2003, 08:25 PM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •