Results 1 to 5 of 5

Thread: Speedometer not working!

  1. #1
    Registered User
    Member ID
    CZCC-2603
    Join Date
    Aug 2002
    Location
    North Platte, NE
    Posts
    113

    Angry Speedometer not working!

    I got my 72 240z about 4 days ago, and the speedo doesn't work. All my other guages work, so I dunno what the problem is. What do I need to fix it? I don't know how it works really, so I need some help. Thanks!
    Sean Heberly
    1972 Datsun 240z 4spd

  2. #2
    Registered User hmsports's Avatar
    Member ID
    CZCC-1615
    Join Date
    Jan 2002
    Location
    St. Louis, MO
    Posts
    577

    Default cable?

    Check the cable that runs from the transmission through the firewall and into the back of the speedo. It could be broken or the gears in the tranny might be stripped?
    Rick Hanson
    HANSON Motorsports
    www.hmsports.com
    rickh@dmrassociates.com

  3. #3
    Registered User
    Member ID
    CZCC-1499
    Join Date
    Dec 2001
    Posts
    4,388

    Default

    It is cable driven off the right side of the transmission.
    Could be the cable has broken, the drive gear has sheered off the pin, or maybe the cable has just slipped enough in the housing that it is no longer in the speedo drive.

    Check the cable at the transmission first, make sure the drive gear is still OK, if it won't turn, it has not sheered the pin off. Check the teeth on the drive gear. If that is OK, try to turn the cable itself to see if it is still engaged in the back of the speedometer.

    You can still get new cables and drive gears, a bit pricey on the cable, but it's better than driving around without a speedo and cheaper than a speeding ticket. MSA has them and probably a few of the better Z suppliers have them as well.

  4. #4
    Registered User Bizza's Avatar
    Member ID
    CZCC-2705
    Join Date
    Aug 2002
    Location
    Melbourne, Australia
    Posts
    22

    Default faulty speedometer

    Ive got the same problem.

    Ok this is how it all started. I was fixing the leak in the speedo driven gear and while i was doing that i pulled the cable that leads to the speedometer. I thingk i pulled it too much and pulled away from it. Now i know it can still work because ive connected a battery drill to the end of the cable, turned it on and the bloody thing went back to life! after thingking it was all good ive cnnected the driven gear back to the tranny and gave her a drive and you guessed it - the gauge did not move a micron . So i thought maybe the cable needs more pushing to get it into gear with the speedometer and it should be sweet again . but it didn't . Now imagine how your reaction would after jacking up the car for ten times knowing that your gonna fix the thing .

    OK my question is does anybody know how to fix the faulty speedo without having to remove the dash board? I don't mind driving without the speedo, but once my dad finds out that it's not working i won't be able to drive my Zed and you all can imagine how that's like.
    ...

  5. #5
    philo "Z" opher Zedrally's Avatar
    Member ID
    CZCC-2363
    Join Date
    Jun 2002
    Location
    Australia
    Posts
    1,818

    Default location...location

    From what you've written, I doubt that it's broken? Else you would not have registed any dial movement when you tried the drill test.
    Doesn't the tranmission end spindle locate into the worm? Maybe, just maybe you haven't located it properly?
    Hope it helps...
    Mike of the Mire

    73 240Z Rally
    77 260Z Touring

    Bogged but not beaten

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •