Results 1 to 10 of 10

Thread: Wouldn't pass smog, what the hell !

  1. #1
    Parts Hero WingZr0's Avatar
    Member ID
    CZCC-13541
    Join Date
    Dec 2006
    Location
    Racerville California
    Age
    38
    Posts
    1,871

    Angry Wouldn't pass smog, what the hell !

    Went to the SMOG place yesterday to get Ruby tested, DIDN'T PASS ! !
    1977 280Z 4 speed by the way in California.

    The guy was cool and over looked the K&N cold air intake and hooked it
    up for free first to where it stood but that has nothing to do with this.

    The numbers came back with a CO (Carbon Monoxide) count of
    6% at idle and the same nuber at 2500rpm.
    He said it being an older car I might be allowed 2% but those numbers
    where WAY TO HIGH.

    Told me she was running extreamly rich on gas and misfiring at idle and
    to have a specialist in these cars check it out.
    A fellow at the tow yard later that day said, "A missaligned
    TPS sensor can cause the problem".

    Calling back at the SMOG place the man said that could be true.
    I found out the new TPS I got from Blake was set on max and dailed it
    down hearing the rpms die down aswell, so I left it at halfway.

    Anyway not wanting to waste my money I made a few trips then took Ruby
    back home and parked her, AGAIN , and had a
    look at her today.

    Found that my oil was at the low level line after being new and full just
    600 miles ago so whats that about ?
    Checked the coolant and it's still clean but the oil was a darker color and
    had a pungent smell like sour gasoline for a lack of a better refernce but
    thats what it seemed.
    Might be me but it did look a little running .

    Must mention while on my rounds I backed out a parking space and
    saw dark colored oil pools on the ground, didn't think it was me though.
    Checked all the usual places today under the engine and oil pump and
    found no signs of any leaks, no where not even the oil pan gasket.
    Also she's not even burning blue oil smoke out the tail pipe so I doubt I'm
    buring it off unless all this has something to due with my valves still
    needing to be adjusted and a head gasket thats very slower seeping
    coolant only and nothing else.

    What should I do or is there more to this problem than a leaky gasket and
    valve job.
    ~Z~
    Last edited by WingZr0; 11-10-2009 at 05:48 PM.
    Speeding is fun,
    As long as you out run,
    The cops! ! !

    ~Z~ Seek Truth

    ウイングゼロ 競争 GangLoadOParts.com

  2. #2
    Former frequent poster sblake01's Avatar
    Member ID
    CZCC-3797
    Join Date
    Mar 2003
    Location
    San Bernardino, Ca. U.S.A.
    Age
    69
    Posts
    10,574

    Default

    Quote Originally Posted by WingZr0 View Post
    I found out the new TPS I got from Blake was set on max and dailed it down hearing the rpms die down aswell, so I left it at halfway.
    Not sure I understand that as there wouln't really be a 'max' setting. Just a right and wrong setting. That could be the main problem as that would affect the fuel mixture. There is a certain procedure to setting the TPS. You want the idle contacts to be closed at idle and the wide open contacts to be closed a wide open. Neither set of contacts is open in between. Its covered on page EF-34 in the 78 FSM.

  3. #3
    Parts Hero WingZr0's Avatar
    Member ID
    CZCC-13541
    Join Date
    Dec 2006
    Location
    Racerville California
    Age
    38
    Posts
    1,871

    Default

    Well i loosened the two mounting screws and you can turn it a little to the left or right. Turn left the revs go up, turn right they go down. But still theres something else that needs to be down? Not sure i understand setting the contacts, is there i link to that part of the FSM you speak?
    Speeding is fun,
    As long as you out run,
    The cops! ! !

    ~Z~ Seek Truth

    ウイングゼロ 競争 GangLoadOParts.com

  4. #4
    Former frequent poster sblake01's Avatar
    Member ID
    CZCC-3797
    Join Date
    Mar 2003
    Location
    San Bernardino, Ca. U.S.A.
    Age
    69
    Posts
    10,574

    Default

    It's on page EF-34 in the 1978 FSM. I don't have a link to just that page and the xenon S30 reference site seems to be down rignt now.

  5. #5
    Registered User conedodger's Avatar
    Member ID
    CZCC-16545
    Join Date
    Apr 2008
    Location
    Reno, NV
    Posts
    2,053

    Default

    It's done with an ohm meter. I haven't done it in years but this could be your problem at idle. Remove your EGR and clean it up too. The water temperature sensor sends a resistence signal as well and if it is all gummed up it could tell the ECU your engine is running hot, causing a rich condition.
    Rob
    2000 BMW R1100 RT-SE (for sale)
    1999 Toyota 4Runner Supercharged
    1975 Porsche 914 stroker motor autoX car
    1973 Datsun 240Z Restoration project. New paint in original white. E31 head on 2.4 block. Nissan Motorsports header. R200 with Nissan motorsports LSD.

  6. #6
    Registered User 70 Cam Guy's Avatar
    Member ID
    CZCC-18904
    Join Date
    Mar 2009
    Location
    Walnut Creek, CA
    Age
    39
    Posts
    567

    Default

    High CO can mean too much fuel or weaker spark (ie incomplete burn). Like everyone has said make sure your TPS is adjusted properly. Temp sensors will also influence how much fuel the computer thinks it needs to add. Can a higher-than-spec fuel pressure cause a rich condition on the 280's?

    Cleaning the EGR and tube is good and will help with the NOx levels.

    You are talking about a couple different problems here. You need a friend to follow you when you drive the car. They can tell you if your getting smoke out the tail pipe on acceleration and/or decel. If you are getting gray-blue smoke on decel that is likely the valve seals. With the closed throttle, you pull a high vacuum that pulls the oil past the oil seals. Also, if you see the blue-gray smoke only after the car sits a little while, that can also be a sign of the valve seals. As the oil pools around the valve stem, it can seep down the valve stem and be burned when you first start the engine.

    If you don't have an apparent external oil leak, and you're losing oil, it's likely being consumed. If your oil smells like gas, you are probably running rich. By the way, most OEM's say that 1 quart per 1000 miles is "normal" consumption, even on new cars.

    Also, be careful what advice you follow from the tow truck driver. I've heard some absolutely crazy things from some of those guys.
    -Andy
    1973 HLS30-166105
    RB20DET swap, HKS GT2530 turbo, HKS Actuator, Hallman MBC, ebay intake manifold, ebay dump pipe, straight pipe, 14 psi boost

  7. #7
    Parts Hero WingZr0's Avatar
    Member ID
    CZCC-13541
    Join Date
    Dec 2006
    Location
    Racerville California
    Age
    38
    Posts
    1,871

    Default

    THAYNX ALL, advice i'll follow. And will definately watch out those toy truckers . Have been smelling gas last few days when flooring it so surely running rich. Will get a bud to follow me around. Deans good at building race cars but i just remembered theres a guy in town that used to be a Nissan Dealer mechanic when these where new. I'll get him to spec her out with ya's tips. Lets get it right the first time, already going through withdrawls . THANX again all. ~Z~
    Last edited by WingZr0; 11-11-2009 at 03:15 AM.
    Speeding is fun,
    As long as you out run,
    The cops! ! !

    ~Z~ Seek Truth

    ウイングゼロ 競争 GangLoadOParts.com

  8. #8
    Do it in a Z Mat M's Avatar
    Member ID
    CZCC-6791
    Join Date
    Jun 2004
    Location
    Sierra Foothills outside of SACRAMENTO, CA
    Posts
    545

    Default

    Got me wondering, was there an end to this story?
    Mat
    AKA MatMan
    MatM@M2Differentials.com

    m2differentials.com


    01/71 HLS30-19724 original 918, 4 speed, ready for the 5 spd swap, and R200 diff from the '81ZX
    08/71 HLS30-41979 multicolored auto, but under the knife - SOLD!!
    81 ZX Grey/blue 5-speed donor car, runs! - SOLD!!
    82 ZX Black auto T-top - motor/3.90 R200 donor car - MOST excellent PAPER WASP condo. - SOLD!!

  9. #9
    Parts Hero WingZr0's Avatar
    Member ID
    CZCC-13541
    Join Date
    Dec 2006
    Location
    Racerville California
    Age
    38
    Posts
    1,871

    Default

    Quote Originally Posted by Mat M View Post
    Got me wondering, was there an end to this story?
    No not yet, she's still parked in the driveway. In the same spot . Found a few more things since then like the leaky clutch slave AATCO Transmission said they replaced but didn't cause it's the same old one it started with. So now for safe measure I have to replace the master and slave for that. Then later the front input shaft seal in the tranny decided to give out so now I'm slowly leaking gear oil out the bellhousing , another thread started on that, and that was with the car just sitting there. At least that part was after it sat for a month fore had it gave out while been driven the gear oil would've gotten on the clutch disc then that would have to been replaced too. Before this all I needed was brakes, or so I thought. Guess the next to go is the shocks and springs . So she's gonna sit covered till I can afford to fix, and replace, everything at once. Least I know the problems now.
    Last edited by WingZr0; 01-06-2010 at 04:21 AM.
    Speeding is fun,
    As long as you out run,
    The cops! ! !

    ~Z~ Seek Truth

    ウイングゼロ 競争 GangLoadOParts.com

  10. #10
    Parts Hero WingZr0's Avatar
    Member ID
    CZCC-13541
    Join Date
    Dec 2006
    Location
    Racerville California
    Age
    38
    Posts
    1,871

    Default

    Took her to Stephens Automotive.
    The Spark wires were installed on the cap wrong he knew something was off but
    couldn't find what at first. Every thing was right and every test came back ok.
    Then he saw the plug wires were installed 180 degress off! They were in the right firing
    order just on the opposite side of the rotor cap.
    Once he put them in the place "She purred like kitten!" he said =)
    So next up is brakes fore I take her in for smog check.
    Last edited by WingZr0; 05-29-2012 at 03:35 AM.
    Speeding is fun,
    As long as you out run,
    The cops! ! !

    ~Z~ Seek Truth

    ウイングゼロ 競争 GangLoadOParts.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Smog test
    By tanny in forum Help Me !!
    Replies: 4
    Last Post: 07-24-2006, 07:42 PM
  2. Will I Pass Smog With Headers?
    By Pennyman in forum Open S30 Z Discussions
    Replies: 11
    Last Post: 07-20-2006, 06:52 PM
  3. Not passing smog. Suggestions appreciated
    By Esteves in forum Open S30 Z Discussions
    Replies: 14
    Last Post: 06-16-2006, 05:12 PM
  4. omitting 280z smog stuff
    By Pennyman in forum Engine and Drivetrain (S30)
    Replies: 4
    Last Post: 10-13-2003, 05:01 PM
  5. will not pass smog!!!
    By xkeithx in forum Help Me !!
    Replies: 4
    Last Post: 05-21-2003, 07:00 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •