Results 1 to 4 of 4

Thread: New z owner. Need some help with ignition cutting out.

  1. #1
    Registered User
    Member ID
    CZCC-24138
    Join Date
    Apr 2011
    Location
    Santa Ana CA
    Age
    37
    Posts
    2

    Default New z owner. Need some help with ignition cutting out.

    Ok going to make it quick and to the point.

    Purchased 72 240z with original engine and 280 dizzy and msd coil. Car ran good but would randomly shut off. No sputter just instant 0 rpm. Pull over and usually would start again within 1-5 min.

    Took to z shop, tech re wired coil. Previous owner had left ballast resistor and mechanic said that it coulda caused problems.
    Mechanic gave me a stock 280 coil and said it was more reliable.

    Car ran fine for a day then same problem. I swapped over to the 280 coil but still same thing.

    Read and read. Found out e12 80 module might be problem. Swapped over to a gm lx 301 type module.
    Fired up car and now won't start at all. Switched back to the e12 80 but now won't start. Changed back to msd coil and nothing.

    Any ideas? What should i do now? Carbs were tuned up when in shop. Im getting no
    Spark when I pull the spark plug wire that goes frm coil to dizzy.

    Hate my first post to be all problems but I have read and searched and need some help please.

    Thanks Quan.

  2. #2
    Registered User
    Member ID
    CZCC-24138
    Join Date
    Apr 2011
    Location
    Santa Ana CA
    Age
    37
    Posts
    2

    Default

    Another question. I attached an aluminum mounting plate on the gm module but haven't mounted the plate onto anything, just kinda dangling around. Does this thing need to be mounted and grounded?

  3. #3
    Registered User ZCurves's Avatar
    Member ID
    CZCC-7312
    Join Date
    Nov 2004
    Location
    Spring, Texas USA
    Age
    55
    Posts
    1,052

    Default

    I have a '78, but I'll throw a few suggestions to you anyway. First, I would get my hands on a Factory Service Manual (FSM) for a 72 240. Look in the Downloads section first, then search for the FSM.
    When you are new to a particular car AND have a lot of complications, it is best to go back to the original setup. I would remove the MSD and GM equipment and revert back to the OEM setup and then begin to test each component and eliminate each variable. This will help you to diagnose the problem rather than throw time and money at it and hope the problem will go away. You have to get to know your new friend.

    Is it correct that you bought the Z with the 280 Distributor already installed by the PO?? It sounds to me like something is shorting out, have you tested the distributor? Is the coil good? What about the Ignition Module? Is the wiring correct and complete?

    There have been many Series 1 guys here that have performed the Distributor conversion w/Electronic Ignition. Search the threads and see if there is something there that will help. I am hoping that some of the 240z members will speak up.

    Good Luck
    Last edited by ZCurves; 04-22-2011 at 08:16 AM.
    Andrew (ZCurves)
    1978 Coupe - HLS30-440105
    Spring, Texas USA

    pro deo et patria
    My Albumz

  4. #4
    Low Budget/High Value
    Member ID
    CZCC-20342
    Join Date
    Oct 2009
    Location
    Washington County, OR
    Posts
    3,629

    Default

    The GM 4 pin module has to be electrically grounded through one of the mounting holes to function. I have read that they can be damaged if they lose ground, so yours may be damaged if you tried it without. Some people (me for one) run a dedicated ground wire from the mounting hole to make sure they have a good connection. The heat sink and the ground serve two different functions.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine Cutting Out Sporadically
    By ONZEDGE in forum Help Me !!
    Replies: 1
    Last Post: 02-17-2010, 11:56 AM
  2. 260z sputtering and cutting off
    By KenshinX in forum Help Me !!
    Replies: 4
    Last Post: 03-09-2009, 07:33 PM
  3. Cutting up an air cleaner for the venturis
    By The Wingnut in forum Carburetors (S30)
    Replies: 10
    Last Post: 07-31-2007, 03:26 PM
  4. Cutting spring coil
    By kmack in forum Open Racing Discussions
    Replies: 17
    Last Post: 06-24-2004, 12:12 PM
  5. cutting fiberglass??
    By uberhahn in forum Body and Paint (S30)
    Replies: 1
    Last Post: 06-07-2003, 08:19 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •