Results 1 to 11 of 11

Thread: Help! Electrical issue: 1973 240z, turn signals work, hazards do not

  1. #1
    Registered User
    Member ID
    CZCC-24896
    Join Date
    Aug 2011
    Location
    California
    Posts
    11

    Default Help! Electrical issue: 1973 240z, turn signals work, hazards do not

    Hey guys,

    My electrical system is stock, but for some reason I can't seem to get the hazard switch to work for the life of me. I noticed that it didn't work when my car died on the side of the road.

    Does anybody know if there a fuse that shorted that I don't know about? When I pull on the 73' hazard switch, the turn signals stop working when you pull on the switch. I looked all around and everythign seemed fine. One thing to note though, is that the cigarette lighter is unplugged. I'm stumped.

    Thanks

  2. #2
    No more body roll! SteveJ's Avatar
    Member ID
    CZCC-5413
    Join Date
    Dec 2003
    Location
    Gainesville, GA
    Age
    53
    Posts
    3,651

    Default

    Start here: Hazard Switch ? Brake Light ? Turn Signal Circuit Analysis | Fiddling With Z Cars
    It's for a 72, but the 73 is essentially the same.
    73 240Z
    74 260Z

    Blue's collection of tech tips - A great place to look for answers
    XenonS30 -The cheap source for FSMs
    Georgia Z Club
    Fiddling with Z Cars - Z car tips & tricks and pictures of my car-loving life.
    Steve's CARtography - Just car pictures.

  3. #3
    Registered User tlorber's Avatar
    Member ID
    CZCC-20299
    Join Date
    Oct 2009
    Location
    Los Angeles
    Age
    54
    Posts
    1,190

    Default

    Those switches are very tempermental and sensitive. On my car it has to be in exactly the correct position or I get turn signal/brake light issues. Try pulling it out our pushing it in very slightly while the turn signal is on to see if it will kick in correctly.

  4. #4
    Registered User 71Nissan240Z's Avatar
    Member ID
    CZCC-19487
    Join Date
    Jun 2009
    Location
    Portland, Oregon
    Age
    36
    Posts
    146

    Default

    Hazard switch lost continuity on the turn signal and brake light side. Gonna clean the contacts tomorrow and see if it works. Ill have to rig a double pole relay two position switch if it dont work or get an O.E.??"

  5. #5
    Registered User 71Nissan240Z's Avatar
    Member ID
    CZCC-19487
    Join Date
    Jun 2009
    Location
    Portland, Oregon
    Age
    36
    Posts
    146

    Default

    Hazard switch lost continuity on the turn signal and brake light side. clean the contacts and see if it works. Or rig a double pole relay two position switch if it dont work or get an O.E.??"

  6. #6
    Registered User
    Member ID
    CZCC-24896
    Join Date
    Aug 2011
    Location
    California
    Posts
    11

    Default

    Thanks guys,

    I'll pull the switch out and clean it this weekend.

  7. #7
    Registered User
    Member ID
    CZCC-24896
    Join Date
    Aug 2011
    Location
    California
    Posts
    11

    Default

    So I cleaned opened the switch, cleaned out the connections, reheated the solder on the wiring and I still don't see hazards :/

    Turn signals work just fine. Does anybody know if the hazards use a separate relay to activate the turn signals?

  8. #8
    Registered User tlorber's Avatar
    Member ID
    CZCC-20299
    Join Date
    Oct 2009
    Location
    Los Angeles
    Age
    54
    Posts
    1,190

    Default

    Hazards DO use a separate relay. I believe it is on the passenger's side, above the kick panel.

  9. #9
    Barn Find Daily Driver Captain_Zeros's Avatar
    Member ID
    CZCC-21373
    Join Date
    Apr 2010
    Location
    Kirkland, WA
    Age
    31
    Posts
    316

    Default

    When you yank the hazard switch, do your turn signals still function? The hazard switch breaks the turn signal circuit and enables a hazard blinker circuit when it's functioning properly. If with the switch pulled out your turn signals still work then it's the switch, if with the switch pulled out you get no hazards AND no turn signals, then go for the hazard blink relay.

  10. #10
    Registered User
    Member ID
    CZCC-24896
    Join Date
    Aug 2011
    Location
    California
    Posts
    11

    Default

    When I yank the hazards, the turn signals no longer works. I'll check the relay. Thanks guys!

  11. #11
    Registered User
    Member ID
    CZCC-24896
    Join Date
    Aug 2011
    Location
    California
    Posts
    11

    Default

    Update:
    turns out, it WAS the flasher that was busted!

    It took me a good 15 min to find the flasher unit, but here it was, tucked away in the back of all the relays. Here's a picture for 1973 Z owners in the future looking for it. It's the cylindrical thing in the center of the picture:
    (view from the passenger door)

    I simply pulled out my turn signal flasher, and plugged it into the hazard and it worked

    Thanks for all the help guys!
    Last edited by yuh; 04-22-2013 at 04:25 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A Question Regarding Turn Signals and Hazards
    By Graverobber in forum Electrical (S30)
    Replies: 14
    Last Post: 04-08-2013, 07:05 PM
  2. headlights and turn signals dont work.
    By Devil_Z in forum Help Me !!
    Replies: 13
    Last Post: 04-07-2010, 02:37 PM
  3. How to have clickin' sound with 240Z turn signals?
    By MyEDY240Z in forum Open S30 Z Discussions
    Replies: 5
    Last Post: 02-13-2005, 09:24 AM
  4. hazards dont work?
    By z_boi in forum Electrical (S30)
    Replies: 4
    Last Post: 01-23-2004, 07:57 AM
  5. 72 240Z Turn Signals
    By Bambikiller240 in forum Help Me !!
    Replies: 5
    Last Post: 05-30-2001, 07:22 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •