Results 1 to 7 of 7

Thread: turn signal fuse keeps blowing.

  1. #1
    Registered User
    Member ID
    CZCC-29979
    Join Date
    Dec 2013
    Location
    wisconsin
    Age
    25
    Posts
    11

    Default turn signal fuse keeps blowing.

    I have a 81 280zxt My flasher fuse keeps blowing as soon as I touch fuse to holder POP!!! Instantly blows my mechanic friend unplugged the turn signal switch it doesn't blow the fuse in there is fine any input/help please & thanks

  2. #2
    Registered User siteunseen's Avatar
    Member ID
    CZCC-24724
    Join Date
    Jul 2011
    Location
    Alabama
    Posts
    1,967

    Default

    You've probably got a loose bulb or wire in one of the fixtures. Take the screws out and remove the lenses for a look.
    1972 240Z #918 New Sight Orange
    1977 280Z #305 Light Blue Metallic
    1972 240Z #110 Persimmons Red

  3. #3
    Registered User
    Member ID
    CZCC-29979
    Join Date
    Dec 2013
    Location
    wisconsin
    Age
    25
    Posts
    11

    Default

    Do you mean the bulbs in the rear in the harness ?

  4. #4
    No more body roll! SteveJ's Avatar
    Member ID
    CZCC-5413
    Join Date
    Dec 2003
    Location
    Gainesville, GA
    Age
    53
    Posts
    3,651

    Default

    You haven't supplied enough information to give a meaningful assessment.

    How long have you owned this car? Has the fuse always blown, or is this a recent occurrence? If it is recent, have you done anything to the car maintenance wise prior to the fuse blowing?

    Was the turn signal turned to the left or right when the fuse was blowing, or would the fuse blow with the switch in the center (off) position?
    73 240Z
    74 260Z

    Blue's collection of tech tips - A great place to look for answers
    XenonS30 -The cheap source for FSMs
    Georgia Z Club
    Fiddling with Z Cars - Z car tips & tricks and pictures of my car-loving life.
    Steve's CARtography - Just car pictures.

  5. #5
    Registered User
    Member ID
    CZCC-29979
    Join Date
    Dec 2013
    Location
    wisconsin
    Age
    25
    Posts
    11

    Default

    Sorry about not giving enough information. So here it goes I got the car in July. the dash wiring was a mess it was hacked up. One of the previous owners tried to but after market gauges in I've pulled all the carpet out the wiring from back until you get to the dash was not messed with the fuse problem has always been there they told me I needed to hook the lights. up but head & tail lights work my hazards work fine and when we put a blown fuse wrapped in tin foil in the holder the turn signals work then and i think its when you flip the switch in either direction it blows and there is a terminal strip by the steering column for extra power we've eliminated most of the mess by pulling those gauges out. Thanks.

  6. #6
    Registered User siteunseen's Avatar
    Member ID
    CZCC-24724
    Join Date
    Jul 2011
    Location
    Alabama
    Posts
    1,967

    Default

    If you have time, read this tech tip on your "combo Switch". Something might ding a bell in your head.

    http://www.kamikazeracing.org/dl/ZTe...mbo_switch.pdf

    And unless this your only night time ride, don't do the tin foil wrapped fuse. You'll end up causing more problems.
    Last edited by siteunseen; 12-31-2013 at 12:50 PM.
    1972 240Z #918 New Sight Orange
    1977 280Z #305 Light Blue Metallic
    1972 240Z #110 Persimmons Red

  7. #7
    Registered User
    Member ID
    CZCC-29979
    Join Date
    Dec 2013
    Location
    wisconsin
    Age
    25
    Posts
    11

    Default

    I don't leave it like that just for a quick second to test it the car isn't drivable at the moment do to other problems but I've been trying to fix this turn signal problem since I got the car

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Keep blowing IGN fuse, no turn sigals, gauges or, tachometer
    By Da Flash in forum Electrical (S30)
    Replies: 23
    Last Post: 08-01-2013, 08:46 PM
  2. wiper fuse keeps blowing
    By wilson_wwsc in forum Electrical (S30)
    Replies: 5
    Last Post: 01-09-2011, 07:39 AM
  3. Headlight fuse keeps blowing
    By liltuber in forum Electrical (S30)
    Replies: 7
    Last Post: 08-12-2009, 07:07 PM
  4. Blowing my IGN fuse bad on '73 Z
    By CamH in forum Electrical (S30)
    Replies: 6
    Last Post: 07-13-2009, 07:28 PM
  5. Alternator fuse keeps blowing
    By cebu in forum Electrical (S30)
    Replies: 1
    Last Post: 06-06-2009, 03:18 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •