Results 1 to 3 of 3

Thread: 1972 240z tends to stall after fully warming up during traffic jams or street lights

  1. #1
    Registered User
    Member ID
    CZCC-29967
    Join Date
    Dec 2013
    Location
    Panama
    Age
    42
    Posts
    157

    Default 1972 240z tends to stall after fully warming up during traffic jams or street lights

    My 240z is tending to fail when it is between 800 to 2,000 RPM. Once it reaches over 3,000 RPM it is really stable.

    I bought this car second hand with the following specifications:

    New Datsun L24 motor with crank and rods from a L26, special oversized 84mm flat top black coated pistons from D.L. Potter Engineering with E88 Head and Far 311 New Race Cam.

    2 original SU Hitachi round top carburetors rebuilt.

    I already used a synchronizer to sync both of the Hitachi carburetors. Another thing i did noticed is that the first three spark plugs are turning black.

    Does the failing problem has something to do with this race cam? During traffic jams or Street light after being driven for 30 minutes it tends to stall lowering the rpm to 700. This really does not feel comfortable.

    Looking for an honest advice as i would not like spending money on an original cam or carburetor if this is not the solution.

  2. #2
    Registered User
    Member ID
    CZCC-29883
    Join Date
    Nov 2013
    Location
    Portland, Or
    Age
    70
    Posts
    283

    Default

    Assuming you've done a recent complete tune up, the front carb sounds like the problem. Check the following; fuel nozzle sticking in the down position when the choke is off. cable adjusted to allow nozzle to return, float level ( you'll need a new gasket), compare piston drop in both carbs(oil cap in & out), everything OK then turn the mixture screw clockwise 1/2 turn, this will lean the mixture in that carb. clean the plugs & drive it. Check back.

  3. #3
    Registered User
    Member ID
    CZCC-29967
    Join Date
    Dec 2013
    Location
    Panama
    Age
    42
    Posts
    157

    Default

    Yesterday I noticed that after running the car for 20 to 30 minutes and then parking the car if i leave the engine on at idle the rpm tends to lower intermittently to 500 rpm. If i decide to turn the lights on it will lower a Little bit more until the engines shuts off.

    This problem is really annoying as i am worried that once i put an AC kit to the car i would be having the car shut off immediately.

    Please advise which direction should i take before installing the AC to the car. I need to have this issue solved ASAP.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1972 240z Temperature rising on idle while traffic and stop lights
    By jalexquijano in forum Engine and Drivetrain (S30)
    Replies: 5
    Last Post: 04-02-2014, 07:39 AM
  2. Pricing 240z Rally Clock w/ Fully Functioning Oscillator?
    By dhp123166 in forum Open S30 Z Discussions
    Replies: 30
    Last Post: 07-13-2011, 07:51 PM
  3. Help! Tail Lights Out! 1972 240z
    By BenyaZ in forum Help Me !!
    Replies: 9
    Last Post: 12-17-2008, 05:37 PM
  4. 1972 240z, no wiring to the back lights
    By JakeWard in forum Electrical (S30)
    Replies: 4
    Last Post: 12-01-2007, 12:55 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •