Results 1 to 5 of 5

Thread: 1970 240Z - Speedo Reads Too Low

  1. #1
    Registered User
    Member ID
    CZCC-28859
    Join Date
    Dec 2012
    Location
    United States
    Age
    55
    Posts
    2

    Default 1970 240Z - Speedo Reads Too Low

    I have a 1970 240Z with the original real end, but with a later model 4-speed manual tranny. The Speedo is reading about 10 mph low at 60 m.p.h. I don't know which speedo cog I have. I think it's the black one. Which one will increase the speed? Should I count the teeth and go to one with more teeth?

    Coop

  2. #2
    Registered User
    Member ID
    CZCC-20445
    Join Date
    Nov 2009
    Location
    long island NY
    Age
    63
    Posts
    125

    Default

    I think you need less teeth so it will turn faster

  3. #3
    Registered User EuroDat's Avatar
    Member ID
    CZCC-26512
    Join Date
    Feb 2012
    Location
    The Netherlands
    Posts
    1,420
    Blog Entries
    1

    Default

    You should check the colour of your speedo gear. If its a manual with the original rear end it should have 3.364:1 diff ratio. The auto's had 3.545:1.

    The 280Z had the 3.545:1 in the manual and autos (R180 and R200). If the transmission came out of this model it will be reading off.
    The speedo gear should be black (17 teeth) for the 280Z with 3.545:1 Diff.
    You should need yellow colour with 16 teeth. Im not completly 100% sure of the part number. You could check with your local dealer. 16 teeth Speedo pinion (Yellow) P/N: 32703-P2616

    Click image for larger version. 

Name:	SpeedoPinion.jpg 
Views:	19 
Size:	24.0 KB 
ID:	72510

    Good luck.
    Chas
    Last edited by EuroDat; 07-02-2014 at 09:14 AM.
    Kurbycar32 likes this.
    Chas
    5/77 280Z HLS30 403100 with some modifications
    Original colour: 305 Light Blue. The PO changed it to Red

  4. #4
    Registered User moelk's Avatar
    Member ID
    CZCC-23183
    Join Date
    Dec 2010
    Location
    Sweden
    Posts
    72

    Default

    Is the speedo showing about 10mph low at all speeds? If so, you could just calibrate the needle in the speedometer.
    Andreas C

  5. #5
    Registered User tlorber's Avatar
    Member ID
    CZCC-20299
    Join Date
    Oct 2009
    Location
    Los Angeles
    Age
    54
    Posts
    1,190

    Default

    I'm not the one with the Captain Obvious avatar, but can't you just drive faster?
    Captain Obvious likes this.
    Tlorber
    '73 240 +/- done
    '73 240 survivor
    '69 SRL 311
    '54 GMC Going onto S10 frame w/LS motor
    '99 Lexus GS Driver

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Plug Reads?
    By Jetaway in forum Engine and Drivetrain (S30)
    Replies: 21
    Last Post: 02-16-2011, 08:27 PM
  2. oil gage reads 0
    By trykflyr in forum Engine and Drivetrain (S30)
    Replies: 4
    Last Post: 08-08-2008, 10:06 AM
  3. tach reads wrong when hot outside
    By Pir0San in forum Electrical (S30)
    Replies: 13
    Last Post: 06-23-2006, 06:10 AM
  4. turbo motor reads 125 psi on all 6
    By LEN168 in forum Engine and Drivetrain (S30)
    Replies: 0
    Last Post: 11-18-2002, 05:57 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •