Results 1 to 3 of 3

Thread: SU Carbs are on but still wont start up

  1. #1
    Registered User
    Member ID
    CZCC-30723
    Join Date
    Aug 2014
    Location
    Rio Rancho New Mexcio
    Age
    25
    Posts
    1

    Default SU Carbs are on but still wont start up

    Hey guys, I have a 11 of 73 260z so it is a 74. When I got the car, it had hitachi flat tops on and after going through all the tests weather or not if I had spark, getting fuel to the carbs, etc... I have a really usefully manual that belongs to my dad, he was the one who got me into Z cars. Anyways, I got a pair of SU round tops of an 72 240z, my dad said that once I get them, and put them on the car should start right up. After putting them on and going through all the tests again, the right carb is getting fuel in the float, but the left carb is a total different story, I cleaned it out and put it back together, but no matter what I do it does not get gas. The only way I can start up the car is by spraying starter fluid and it will fire up, but it does not hold its idle. I am at a lose right now, can anyone give me some insight and advice?

  2. #2
    Registered User Stanley's Avatar
    Member ID
    CZCC-24191
    Join Date
    Apr 2011
    Location
    Redondo beach
    Posts
    641

    Default

    Yes, someone can. They're probably going to need to see some pictures of this car, though, something about it's history, and so on. Was it running OK with the flat tops?
    What test did you do?
    Maybe one of three things. Clogged banjo bolt or filter, clogged float valve, kinked nozzle hose, low float setting, high mix setting, clogged nozzle, stuck piston, linkage not adjusted, butterfly out of adjustment, choke not adjusted, fuel rail or hose plugged. Ok twelve. Maybe more but that's all I can think of.

    Sounds like a minor issue if it was running before.

  3. #3
    Registered User tlorber's Avatar
    Member ID
    CZCC-20299
    Join Date
    Oct 2009
    Location
    Los Angeles
    Age
    54
    Posts
    1,190

    Default

    Also make sure the nozzles are dropping down when the choke lever is pulled. If you can't richen the mixture, the car will probably not hold an idle until warmed up. If this comment or the one above do not make sense, you need to get hold of the Z therapy carb video and watch it a few times.
    Tlorber
    '73 240 +/- done
    '73 240 survivor
    '69 SRL 311
    '54 GMC Going onto S10 frame w/LS motor
    '99 Lexus GS Driver

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 71 240z with l28e w/ SU carbs wont start... PLS HELP!!!
    By Mr.Green the Great in forum Help Me !!
    Replies: 11
    Last Post: 07-30-2013, 06:21 PM
  2. gages wont work and car wont start with key
    By ZTEC in forum Help Me !!
    Replies: 0
    Last Post: 04-12-2010, 10:39 PM
  3. Car wont start!!!
    By Aussie260z in forum Open 240K Discussion
    Replies: 1
    Last Post: 09-19-2006, 10:59 PM
  4. wont start
    By candysutton in forum Help Me !!
    Replies: 2
    Last Post: 01-28-2004, 11:48 PM
  5. New carbs, wont start
    By Alfadog in forum Help Me !!
    Replies: 4
    Last Post: 08-24-2003, 09:28 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •