Results 1 to 5 of 5

Thread: Left turn signal works fine but not the right

  1. #1
    Registered User Da Flash's Avatar
    Member ID
    CZCC-3103
    Join Date
    Nov 2002
    Location
    So. Cal
    Posts
    90

    Default Left turn signal works fine but not the right

    A few months ago, I re-installed my dash after finding and fixing a short. The cars been running great with the exception of the right (passenger side) T/S. If I put the switch to the left, all is fine the left front/rear/dash lights flash at the normal speed but, if I put it on the right side, none of the lights flash and I only hear 1 click then nothing.

    I first rechecked the wires under the dash and the clamshell, it looks ok but I don't have a point of reference to compare it

    Does anyone have a suggestion so that I can narrow it down??

    Thanks in advance!!
    '71 240z, L28/N42 block, flattop pistons, mildly ported and polished N42 head, ZX 5-speed, stock SU's, ZX Dizzy w/12-80, 6-2-1 header, 2.5" mandrel bend exhaust, tokico illuminas and springs, all new polyurethane bushings. Runs great but, looks like crap!!! 1991 300ZXTT that's a work in progress!!

  2. #2
    No more body roll! SteveJ's Avatar
    Member ID
    CZCC-5413
    Join Date
    Dec 2003
    Location
    Gainesville, GA
    Age
    54
    Posts
    3,651

    Default

    Read through these. Most of your questions should be answered.
    Focus on your turn signal switch.
    Turn Signal Repair | Fiddling With Z Cars
    Hazard Switch ? Brake Light ? Turn Signal Circuit Analysis | Fiddling With Z Cars
    73 240Z
    74 260Z

    Blue's collection of tech tips - A great place to look for answers
    XenonS30 -The cheap source for FSMs
    Georgia Z Club
    Fiddling with Z Cars - Z car tips & tricks and pictures of my car-loving life.
    Steve's CARtography - Just car pictures.

  3. #3
    Registered User Da Flash's Avatar
    Member ID
    CZCC-3103
    Join Date
    Nov 2002
    Location
    So. Cal
    Posts
    90

    Default

    Thanks for the nudge in the right direction. I'll check it out and report back what I find.
    '71 240z, L28/N42 block, flattop pistons, mildly ported and polished N42 head, ZX 5-speed, stock SU's, ZX Dizzy w/12-80, 6-2-1 header, 2.5" mandrel bend exhaust, tokico illuminas and springs, all new polyurethane bushings. Runs great but, looks like crap!!! 1991 300ZXTT that's a work in progress!!

  4. #4
    Registered User Da Flash's Avatar
    Member ID
    CZCC-3103
    Join Date
    Nov 2002
    Location
    So. Cal
    Posts
    90

    Default

    Quote Originally Posted by SteveJ View Post
    Read through these. Most of your questions should be answered.
    Focus on your turn signal switch.
    Turn Signal Repair | Fiddling With Z Cars
    Hazard Switch ? Brake Light ? Turn Signal Circuit Analysis | Fiddling With Z Cars
    Well after screwing around with that damned switch!! (In this case "screwing" means disassembling and reassembling 5 times!!) I got left and right signals!!!! The first dis and reassemble was tedious trying not to lose anything and get the tabs off/on without breaking anything. By the 5th time, I had it apart and back together in minutes!!

    Master Jedi SteveJ, the Force is strong with you!!!
    '71 240z, L28/N42 block, flattop pistons, mildly ported and polished N42 head, ZX 5-speed, stock SU's, ZX Dizzy w/12-80, 6-2-1 header, 2.5" mandrel bend exhaust, tokico illuminas and springs, all new polyurethane bushings. Runs great but, looks like crap!!! 1991 300ZXTT that's a work in progress!!

  5. #5
    No more body roll! SteveJ's Avatar
    Member ID
    CZCC-5413
    Join Date
    Dec 2003
    Location
    Gainesville, GA
    Age
    54
    Posts
    3,651

    Default

    I'm glad to hear you got it working.
    73 240Z
    74 260Z

    Blue's collection of tech tips - A great place to look for answers
    XenonS30 -The cheap source for FSMs
    Georgia Z Club
    Fiddling with Z Cars - Z car tips & tricks and pictures of my car-loving life.
    Steve's CARtography - Just car pictures.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. One Headlight Works Fine, The Other is Dim
    By Otto Skorzeny in forum Electrical (S30)
    Replies: 11
    Last Post: 10-12-2013, 06:13 AM
  2. Problem with left turn signal and side indicator lamps
    By tstewart in forum Electrical (S30)
    Replies: 10
    Last Post: 09-15-2009, 06:51 AM
  3. only one turn signal works
    By winstonsmith in forum Electrical (S30)
    Replies: 11
    Last Post: 09-30-2005, 07:20 PM
  4. Turn signal makes my headlights turn off?!?!
    By BadDog in forum Help Me !!
    Replies: 3
    Last Post: 03-31-2002, 04:12 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •