Results 1 to 2 of 2

Thread: rear turn signals not working

  1. #1
    Registered User
    Member ID
    CZCC-22704
    Join Date
    Oct 2010
    Location
    reading,pa
    Age
    33
    Posts
    1

    Default rear turn signals not working

    hey guy i am new to the older z world and need some help. I have a 72 240z and the rear turn signals are not working now. I changed the flasher on the drivers side under the dash and i have checked the fuses that are under the choke and they are fine. when i use my hazards they work but when i turn the right or left signal lights on the brake light goes out but nothing in the back is blinking the front works fine. i saw in other post that the turn signal switch could be bent if the lights dont work on one side but i dont get why both are out. can anyone help ?

  2. #2
    Registered User tlorber's Avatar
    Member ID
    CZCC-20299
    Join Date
    Oct 2009
    Location
    Los Angeles
    Age
    55
    Posts
    1,190

    Default

    Both sides get deflected over time. I have to open mine up again for the fronts. One thing that helps is to get an electronic flasher rather than a thermal one. Per Dave Irwin, it requires less amperage to drive them so contacts won't arc as badly and, you don't need as good a connection to feed them a signal.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Turn Signal Diagram.jpg 
Views:	52 
Size:	173.9 KB 
ID:	38523  
    Last edited by tlorber; 10-15-2010 at 11:17 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loop pile carpet, any recent purchases? (2008)
    By Arne in forum Interior (S30)
    Replies: 133
    Last Post: 04-29-2010, 09:58 AM
  2. My turn signals are dead.
    By bbcountach in forum Electrical (S30)
    Replies: 11
    Last Post: 11-28-2007, 07:18 PM
  3. Turn Signals
    By 76BlueZ in forum Help Me !!
    Replies: 6
    Last Post: 07-03-2006, 12:45 PM
  4. Dead Tach, Gauges and turn signals
    By Herb in forum Electrical (S30)
    Replies: 13
    Last Post: 03-05-2005, 08:18 AM
  5. 72 240Z Turn Signals
    By Bambikiller240 in forum Help Me !!
    Replies: 5
    Last Post: 05-30-2001, 07:22 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •