Results 1 to 5 of 5

Thread: New Dizzy Cap and rotor. Now the car wont start!

  1. #1
    Newbie ninjazombiemaster's Avatar
    Member ID
    CZCC-27888
    Join Date
    Aug 2012
    Location
    Salt Lake City, Utah
    Age
    27
    Posts
    402

    Default New Dizzy Cap and rotor. Now the car wont start!

    Today I replaced my distributor cap and rotor. I have a pertronix electronic ignition in their. I touched absolutely nothing else, at all. I have checked the firing order about a dozen times, but the car absolutely will not start anymore. I drove it about 5 minutes before doing the change. The car cranks, and after cranking, it actually does fire a few times like its running on two cylinders for a few seconds before dying. So there has to be some ignition happening. I pulled the spark plugs, they look fine. After all, the car just ran. What could I be missing?
    1973 240z w/ ztherapy round top conversion.

  2. #2
    Supporting Member
    Member ID
    CZCC-12938
    Join Date
    Oct 2006
    Location
    ON
    Posts
    2,232

    Default

    Have you made a visual comparison between the old and new caps and rotors? If so and nothing is readily apparent, try putting the old rotor back in and if that does nothing try swapping the old cap back on as a process of elimination. If that doesn't get results you will have to use the standard troubleshooting flow chart to track down the problem. Good luck!

  3. #3
    Newbie ninjazombiemaster's Avatar
    Member ID
    CZCC-27888
    Join Date
    Aug 2012
    Location
    Salt Lake City, Utah
    Age
    27
    Posts
    402

    Default

    Thanks for the reply. Old parts are identical, just more worn... Putting them back on I still had no luck.. BUT! While I was working on that I had an idea. What I did was crank the engine over TDC and noticed that the rotor was not pointing at #1, but at #4. I offset the wires by one, counter clockwise and it fired right up. I don't know if somehow I offset them in the wrong spot (more likely) or if somehow TDC offset during the installation (less likely).
    1973 240z w/ ztherapy round top conversion.

  4. #4
    Registered User madkaw's Avatar
    Member ID
    CZCC-7622
    Join Date
    Dec 2004
    Location
    bloomington IN
    Age
    58
    Posts
    2,288

    Default

    Yep- you screwed up- it happens
    Steve
    71 240z,bw-5sp 2.4-40 over,balanced,e-88,big valves,ported&polished, stage2,header, triple Mikuni's 40's
    3.90 Subaru STI LSD

  5. #5
    Newbie ninjazombiemaster's Avatar
    Member ID
    CZCC-27888
    Join Date
    Aug 2012
    Location
    Salt Lake City, Utah
    Age
    27
    Posts
    402

    Default

    Quote Originally Posted by madkaw View Post
    Yep- you screwed up- it happens
    Haha, indeed it does! Good way to make an easy job frustrating..
    1973 240z w/ ztherapy round top conversion.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gages wont work and car wont start with key
    By ZTEC in forum Help Me !!
    Replies: 0
    Last Post: 04-12-2010, 10:39 PM
  2. Spark issues... Won't start (72 w/ ZX dizzy)
    By e_racer1999 in forum Electrical (S30)
    Replies: 3
    Last Post: 06-21-2009, 06:03 PM
  3. anyone got an electronic dizzy rotor?
    By khughes in forum Electrical (240K)
    Replies: 8
    Last Post: 03-11-2007, 10:56 PM
  4. Car wont start?
    By Nutz in forum Help Me !!
    Replies: 1
    Last Post: 05-09-2006, 06:17 AM
  5. 280 Dizzy cap and rotor?
    By Bill8o240z in forum Australia and New Zealand
    Replies: 2
    Last Post: 03-26-2006, 06:46 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •