Results 1 to 4 of 4

Thread: Thermo switch needed!

  1. #1
    Registered User
    Member ID
    CZCC-23474
    Join Date
    Jan 2011
    Location
    California
    Age
    66
    Posts
    1

    Default Thermo switch needed!

    I have a 1979 280ZX 2+2 and need a replacement THERMO SWITCH sensor for the blower/fan on top of the engine. Without the blower going on after driving, the car builds up heat and developes vapor lock or something similar to it. If the blower goes on there's no problem, but most of the time it's not going on, and the blower itself is functional. It's the switch. Nissan part number is 21595-P8100. I've tried dealers and a number of Z-part outfits to no avail. Help!

  2. #2
    Registered User palladin's Avatar
    Member ID
    CZCC-17841
    Join Date
    Sep 2008
    Location
    Chattanooga
    Posts
    16

    Default

    The switch works AFTER the car is shut off and only IF the temp exceeds certain parameters. It may not be the switch at all. I live in TN and it is rare even in the summer that it kicks on. You can trigger it manually if you have to. If I recall the switch connects the ground to the timer relay, after which the switch is not needed. Verify this before trying it by researching the factory service manual available at www.xenons130.com. If correct, you could install a push button switch to perform that same function.

  3. #3
    Registered User
    Member ID
    CZCC-26864
    Join Date
    Apr 2012
    Location
    Durango, Colorado, United States
    Posts
    692

    Default

    SMP/STANDARD TS-193 Switch, Radiator Cooling Fan (Thermo) (Fits: 280ZX)

    There are a dozen of these for sale on ebay at any given time, or you can google it and find other suppliers.

  4. #4
    Registered User
    Member ID
    CZCC-26864
    Join Date
    Apr 2012
    Location
    Durango, Colorado, United States
    Posts
    692

    Default

    get on ebay and search 280zx temp or "280zx switch" there are several folks selling new ones.

    First confirm that's your problem and not a burned up motor or fuse. Ground the lead and then shut the motor off and see if the fan runs on.

    Ebay's about $50 for that switch, I got lucky and found one for $15 so if you're not in a hurry, might watch awhile.

    My fan STILL isn't kicking in, the switch says 210 on it, so maybe it's just not hot enough yet. It's been starting good, so I haven't worried about it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fog Lamp Wiring Part 2
    By EScanlon in forum Tech Pubs and HowTo
    Replies: 0
    Last Post: 10-11-2006, 02:10 PM
  2. thermo time switch part#
    By 78 280zcar in forum Help Me !!
    Replies: 0
    Last Post: 04-09-2006, 06:07 PM
  3. foglights and the parking light harness upgrade....
    By xray in forum Electrical (S30)
    Replies: 3
    Last Post: 02-26-2006, 08:39 PM
  4. 72 240Z Brake Light Wiring
    By 72SLOZ in forum Tech Pubs and HowTo
    Replies: 0
    Last Post: 07-02-2005, 03:35 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •