Results 1 to 4 of 4

Thread: Headlights not working

  1. #1
    Registered User
    Member ID
    CZCC-29943
    Join Date
    Dec 2013
    Location
    Indialantic, Florida
    Age
    52
    Posts
    1

    Default Headlights not working

    Just bought this car new to the forum. My headlights stopped working but my parking lights still work. Could it be the switch? any help appreciated. Thanks Matt


    Click image for larger version. 

Name:	20131204_131927.jpg 
Views:	65 
Size:	147.7 KB 
ID:	69598 1970 240Z all original

  2. #2
    Registered User beermanpete's Avatar
    Member ID
    CZCC-21519
    Join Date
    Apr 2010
    Location
    Northridge, California, U.S.A.
    Age
    57
    Posts
    631

    Default

    Yes, it could be the switch. That is a common problem. Exercising the switch. It may improve somewhat through use as this tends to wipe off dirt and oxidation that can build up on the switch contacts. Also, each headlight has its own fuse, so check those as well.

  3. #3
    Low Budget/High Value
    Member ID
    CZCC-20342
    Join Date
    Oct 2009
    Location
    Washington County, OR
    Posts
    3,629

    Default

    Pretty common, also, for the ground side to get gummed up. There are two switches - one to supply power and the other to provide a ground. It's the high/low dimmer switch in the turn signal assembly. I've fixed two by squirting contact cleaner in to the switch and working it.

    I've also fixed a power switch by tightening the little tabs on the side of the circuit board (two circuits). It's on top of the column. But if you have the column cover off and you're there it might be worthwhile to bend the tabs back and take it apart. The contacts get pitted over time and can be cleaned up. Watch out for the little parts and remove the power source first.
    1976 280Z, with some minor modifications

  4. #4
    Registered User
    Member ID
    CZCC-29634
    Join Date
    Sep 2013
    Location
    Maryville, Tennessee
    Posts
    20

    Default

    You guys are awesome! My headlights weren't working, I found this thread, went out there and opened up the column switch, jiggled the switches, and BOOM, headlights!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No headlights! All other lights are working
    By Da Flash in forum Electrical (S30)
    Replies: 6
    Last Post: 11-18-2011, 09:20 PM
  2. Trying to get my headlights working
    By FlameThrower in forum Electrical (S30)
    Replies: 10
    Last Post: 06-11-2007, 03:50 PM
  3. '78 280z Headlights Not Working
    By Gilzee in forum Help Me !!
    Replies: 1
    Last Post: 07-31-2004, 09:51 AM
  4. Headlights not working
    By PUSHER in forum Electrical (S30)
    Replies: 1
    Last Post: 05-30-2004, 07:19 AM
  5. Headlights not working
    By feral in forum Help Me !!
    Replies: 1
    Last Post: 07-02-2000, 03:56 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •