Results 1 to 7 of 7

Thread: Electrical gremlins

  1. #1
    Registered User
    Member ID
    CZCC-30326
    Join Date
    Apr 2014
    Location
    Garner, NC
    Posts
    24

    Default Electrical gremlins

    Well my car has sat for 14 years and it runs great I cleaned all of the electrical connectors then applied dielectric grease. the car started randomly cutting off well I have checked it is the ignition relay. I pulled it out and apart it was full of water so I cleaned it with contact cleaner and it wroked for about 30 seconds . So I ordered a new one from courtesy parts. My big plan is with in the next 2-3 weeks I am going to replace all the relays. is ther any thing else I should be worried about ?

  2. #2
    Registered User siteunseen's Avatar
    Member ID
    CZCC-24724
    Join Date
    Jul 2011
    Location
    Alabama
    Posts
    1,967

    Default

    I'd be worried about how the ignition relay got full of water.
    1972 240Z #918 New Sight Orange
    1977 280Z #305 Light Blue Metallic
    1972 240Z #110 Persimmons Red

  3. #3
    No more body roll! SteveJ's Avatar
    Member ID
    CZCC-5413
    Join Date
    Dec 2003
    Location
    Gainesville, GA
    Age
    54
    Posts
    3,651

    Default

    Do you store your car outside? It sounds like you have a leak around your windshield.

    Anyway, I would expect that you'll hear back from Courtesy that the ignition relay is NLA. If that happens, send me a PM. I can make a replacement for you.
    73 240Z
    74 260Z

    Blue's collection of tech tips - A great place to look for answers
    XenonS30 -The cheap source for FSMs
    Georgia Z Club
    Fiddling with Z Cars - Z car tips & tricks and pictures of my car-loving life.
    Steve's CARtography - Just car pictures.

  4. #4
    Registered User
    Member ID
    CZCC-30326
    Join Date
    Apr 2014
    Location
    Garner, NC
    Posts
    24

    Default

    Quote Originally Posted by siteunseen View Post
    I'd be worried about how the ignition relay got full of water.
    Quote Originally Posted by SteveJ View Post
    Do you store your car outside? It sounds like you have a leak around your windshield.

    Anyway, I would expect that you'll hear back from Courtesy that the ignition relay is NLA. If that happens, send me a PM. I can make a replacement for you.
    The windshield does leak because of a huge gap in the rubber. it is on the list .

    Steve I will let you know if they say they do not have it.

    What is needed to build one?

  5. #5
    No more body roll! SteveJ's Avatar
    Member ID
    CZCC-5413
    Join Date
    Dec 2003
    Location
    Gainesville, GA
    Age
    54
    Posts
    3,651

    Default

    I use a dual relay socket, two SPDT relays, one ring lug and a 6 pin connector. The wiring diagram is on this site. You just have to search for it. If you're in a hurry to get the car going, I could have one in the mail to you tomorrow. I have all the parts.
    73 240Z
    74 260Z

    Blue's collection of tech tips - A great place to look for answers
    XenonS30 -The cheap source for FSMs
    Georgia Z Club
    Fiddling with Z Cars - Z car tips & tricks and pictures of my car-loving life.
    Steve's CARtography - Just car pictures.

  6. #6
    Registered User
    Member ID
    CZCC-30326
    Join Date
    Apr 2014
    Location
    Garner, NC
    Posts
    24

    Default

    Quote Originally Posted by SteveJ View Post
    I use a dual relay socket, two SPDT relays, one ring lug and a 6 pin connector. The wiring diagram is on this site. You just have to search for it. If you're in a hurry to get the car going, I could have one in the mail to you tomorrow. I have all the parts.
    Actually figured it out I did not have a 6 pin connector but used blade terminals and one ring terminal

  7. #7
    Registered User
    Member ID
    CZCC-30326
    Join Date
    Apr 2014
    Location
    Garner, NC
    Posts
    24

    Default

    Well built my own relay worked great. Drove car down to get something to eat after 30 min of sitting I went to leave and no start. I get the car home run every test in the FSM and bible. I am loosing signal from pickup when I have a hot soak.I ordered a new pick up and will let you know.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Electrical gremlins
    By mjr45 in forum Open S30 Z Discussions
    Replies: 5
    Last Post: 07-21-2012, 07:21 PM
  2. Electrical Gremlins: Ignition and Temp Gauge
    By jfa.series1 in forum Help Me !!
    Replies: 21
    Last Post: 09-05-2011, 09:06 PM
  3. Replies: 8
    Last Post: 07-23-2011, 04:54 AM
  4. Electrical Gremlins
    By daveinc in forum Electrical (S30)
    Replies: 5
    Last Post: 08-25-2005, 07:52 PM
  5. 1978 280Z electrical gremlins
    By mdbrandy in forum Electrical (S30)
    Replies: 12
    Last Post: 01-23-2004, 05:41 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •