Results 1 to 4 of 4

Thread: Accidental Steam Cleaning-Now Rough Running

  1. #1
    Registered User n2deep's Avatar
    Member ID
    CZCC-23905
    Join Date
    Mar 2011
    Location
    Albuquerque
    Age
    65
    Posts
    34

    Default Accidental Steam Cleaning-Now Rough Running

    On a test drive today after repairing new injector with bad factory crimp, the short hose from thermostat housing line to manifold blew going 80 mph. Instant steam everywhere. I hobbled off the exit and parked ASAP. The temp gauge pegged. The driver side of the engine bay was pretty soaked. After I repaired the hose and got some water in it, it started and got me home but it ran rough all the way. Do you think its running rough because some things are wet or is it possible I did some more serious damage?

    77 280Z

    n2deep

  2. #2
    Nova Scotia,Canada,Earth Blue's Avatar
    Member ID
    CZCC-7641
    Join Date
    Jan 2005
    Location
    NS
    Posts
    4,085

    Default

    clean the throttle valve switch then dry it.

    Also check temp sensor connections.
    There is scarcely anything in the world that some man cannot make a little worse, and sell a little more cheaply.
    The person who buys on price alone is this man's lawful prey.


    John Ruskin (1819 - 1900)



    ZCars in Eastern Canada seaport ready for shipment to Europe

    http://ZSportCanada.com


  3. #3
    Registered User beermanpete's Avatar
    Member ID
    CZCC-21519
    Join Date
    Apr 2010
    Location
    Northridge, California, U.S.A.
    Age
    57
    Posts
    631

    Default

    Check for water in the distributor. It will condense on the cap and cause problems.

  4. #4
    Registered User n2deep's Avatar
    Member ID
    CZCC-23905
    Join Date
    Mar 2011
    Location
    Albuquerque
    Age
    65
    Posts
    34

    Default

    Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rough Running
    By ONZEDGE in forum Help Me !!
    Replies: 0
    Last Post: 07-31-2008, 08:51 PM
  2. Steam Cleaning ... opinons please ...
    By 280z1975 in forum Open S30 Z Discussions
    Replies: 3
    Last Post: 12-07-2007, 09:48 PM
  3. Rough Running
    By ZTEC in forum Engine and Drivetrain (S30)
    Replies: 2
    Last Post: 05-30-2007, 09:00 AM
  4. Engine prep for steam cleaning?
    By gogriz91 in forum Misc (S30)
    Replies: 0
    Last Post: 08-18-2006, 02:09 PM
  5. Rough Running
    By aardvark in forum Engine and Drivetrain (S30)
    Replies: 0
    Last Post: 06-15-2003, 07:58 PM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •