Results 1 to 4 of 4

Thread: Frame Rail Rust

  1. #1
    Registered User 2-77zs's Avatar
    Member ID
    CZCC-2729
    Join Date
    Aug 2002
    Location
    NY Nattive in Utah
    Posts
    44

    Default Frame Rail Rust

    I recently purchased 2 very nice 1977 280 zx's. I paid 50.00 a piece for them. At a total cost of $100.00 neither could be considered part cars. Both run well with little body damage.
    However, one of them sat in the (not so smart) previous owners back yard for about a year. I jacked the car and notice some rust on the passenger side frame rail. Not alot, but enough to make me nervous. I read ZcarsRock posting about how he shoved steele beams inside the rails then "bolted them" in. I WOULD TRULY LIKE TO AVOID SUCH A TACTIC.
    Can any of you point me to a starting place concerning this problem?
    Thank you in advance for your help.
    TS

  2. #2
    Registered User
    Member ID
    CZCC-1499
    Join Date
    Dec 2001
    Posts
    4,388

    Default

    First thing to do is to find out if it is just surface rust or if has gone beyond that. Take a small screwdriver under there and push against it. If it doesn't go through you are in good shape. Clean it and paint it or use a rust inhibitor like POR-15 on it. If it goes through or you find any weakness, you should either patch or replace. You can do the same test on the front frame rails, rocker panels (in an inconspicuous place), under the battery tray and all the other places a Z normally rust. You don't have to beat on it, a simple push will tell you all you need to know. If it is weakened from the inside you will notice a lot of give in the metal or you may even poke a hole in it, in that case it's time to start welding.

    Do a search here using the search function on the main page and you should come up with numerous posts on rust problems and how to repair them. If you can't find the answer to your dilemma, we are always here to answer more questions.

    Oh, a 77 is a 280Z, the ZX's started in 79 in the US.

  3. #3
    Registered User 2-77zs's Avatar
    Member ID
    CZCC-2729
    Join Date
    Aug 2002
    Location
    NY Nattive in Utah
    Posts
    44

    Default

    HUH, Just goes to show you the extent of Zcar knowledge I'm working with over here. Hope I can change my login name so's not to remain an ass.
    Thank you for the help, I will do as you directed, then ask from there.
    Great site, glad I found it.
    TS

  4. #4
    Registered User 2-77zs's Avatar
    Member ID
    CZCC-2729
    Join Date
    Aug 2002
    Location
    NY Nattive in Utah
    Posts
    44

    Default

    Since I do not feel as though the rust is enough to effect the suspension and handling of the car, I have taken this thread to it's proper location in "Body & Paint". Thanks
    TS

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •